CVE-2016-3962-3988-39892016-10-12T16:53:57+00:00

SUMMARY

The following vulnerabilities were found in the Meinberg NTP Time Server Web Interface:

CVE-2016-3962-3988

Version 5.x.x (CVE-2016-3962) and Version 6.x.x up to 6.20.004 (CVE-2016-3962) of the web configuration interface on all Meinberg NTP time server devices contain multiple remotely exploitable buffer overflow vulnerabilities in the functions responsible for parsing incoming HTTP requests. The vulnerable functions do not properly validate the size of incoming data before copying the data into statically sized buffers on the stack. Exploitation of these vulnerabilities does not require authentication and can lead to code execution under the privilege level of the running web server.

CVE-2016-3989

All Meinberg NTP time server devices up to version 6.20.004 are running a daemon called lantimed that allows for privilege escalation to root user.  This particular daemon provides a function that copies a script controlled by the webserver to a privileged location which can then be run as the root user. Exploitation of this vulnerability does not require authentication and can lead to escalation of privilege from the webserver user to root user.

 

 

 

IMPACT

IMPACT

Access Vector:
Complexity:
Authentication:
Impact Type:
Privilege Level:

Remote
Low
None
Code Execution
Unprivileged

Access Vector:
Complexity:
Authentication:
Impact Type:
Privilege Level:

Local
Low
None
Privilege Escalation
Root

AFFECTED PRODUCTS

  • IMS-LANTIME M3000
  • IMS-LANTIME M1000
  • IMS-LANTIME M500
  • LANTIME M900
  • LANTIME M600
  • LANTIME M400
  • LANTIME M300
  • LANTIME M200
  • LANTIME M100
  • SyncFire 1100
  • LCES Version

SOFTWARE FIXES

  • Please update to firmware version 6.20.004. The update can be downloaded here.

TIMELINE

REFERENCES